Tuesday, 27 August 2013

ConfigMgr 2007 - Unknown Computer Deployments 'cached'

Just had a bit of a problem in an old ConfigMgr 2007 environment with an old Operating System Deployment task sequence, advertised to Unknown Computers collection. Unknown computer support was going to be removed from this company.

This manifested itself in the following manner:
  • Old advertisement targeted to Unknown Computers was disabled a number of weeks ago
  • Unknown computers were still picking up this disabled advertisement and attempting to run it
The SMSPXE log would show an unknown computer booting, and being offered a DISABLED advertisement. Which was a source of confusion, to say the least. WDS service was restarted on one of the PSPs to determine if there was any kind of computer records being cached - this did not resolve the issue.

In the end, the fix for this was to force an update of the collection membership of the Unknown Computers collection. After this was forced, unknown computers would not pick up the old (disabled) advertisement, and everything was peachy.

This may be a strange issue isolated to one particular ConfigMgr instance, but thought i'd share in case this helps anyone.I'm assuming that the old advertisement assignment to the unknown computer objects had never been refreshed. However, i would have thought disabling the Advertisement would have gotten past this issue.

 If anyone knows the actual, for-real cause of this, sing out in the comments. 

No comments:

Post a Comment